Installing Deluge

These are the instructions for installing Deluge. Consider them a work-in-progress and feel free to make suggestions for improvement.

Ubuntu

PPA

Until the stable PPA is updated, the development version of Deluge can be used:

sudo add-apt-repository -u ppa:deluge-team/stable
sudo apt install deluge

PyPi

To install from Python PyPi, Deluge requires the following system installed packages:

sudo apt install python3-pip python3-libtorrent python3-gi python3-gi-cairo gir1.2-gtk-3.0 gir1.2-appindicator3

Install with pip:

pip install deluge

Windows

Unfortunately due to move to GTK3 and Python 3 there is no installer package currently available for Windows.

Intrepid users can install Deluge from separate packages as detailed in issue #3201.

macOS

There is no .app package currently for macOS, but can try Deluge with Homebrew.

  1. Install Homebrew

  2. Open a terminal.

  3. Run the following to install required packages:

    brew install pygobject3 gtk+3 adwaita-icon-theme
    brew install libtorrent-rasterbar
    
  4. To fix translations:

    brew link gettext --force
    
  5. Install Deluge:

    pip3 install deluge